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How to create forms
You can use forms to interact with or gather information from site visitors. With forms, visitors can provide feedback, 
sign a guest book, take a survey, or place an order for merchandise. In Adobe Dreamweaver CS5, you can create a 
variety of form elements, such as text fields, password fields, radio buttons, checkboxes, pop-up menus, and clickable 
images (such as a Submit button).


The Forms category in the Insert panel (Figure 1) contains buttons for creating forms and inserting form elements.


Figure 1 Forms category in the Insert panel


The data gathered in forms is usually sent to a database on a server or through e-mail. To set up the form processing, 
contact your site administrator. This guide helps you make the user interface of a form.
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Setting up a form


You set up a form by inserting it and configuring options through the Property inspector.


To set up a form:


1. Open a page in Dreamweaver.


2. Place the insertion point on the page where you want to 
insert a form or draw a new div for more precise 
positioning of the form on your page. 


Note: To draw a new div, click Draw AP Div in the 
Layout category in the Insert panel, and then drag to draw 
the div. Be sure to make the div large enough to contain 
the entire form you plan to create.


3. Select the Forms category in the Insert panel (Figure 1), 
and click Form. 


A blank form appears, with a red dotted outline 
(Figure 2). You place all form elements inside this 
outline. If you placed the form inside a div, you may need 
to click outside the div to see the entire form outline.


Form options appear in the Property inspector.


4. From the Method pop-up menu in the Property inspector 
(Figure 3), select either GET or POST.


• GET appends the form contents to the URL specified 
in the Action text box. Use GET if the form data is 
short and the results of the form will lead to a page 
that you want the visitor to be able to bookmark.


• POST sends the form contents directly to the server 
in a manner that is not visible to the visitor. Use 
POST if the form data might be long (if, for instance, 
the form includes a text field that the visitor can use 
to type an unlimited amount of text). 


5. In the Action text box, type the URL or CGI script that 
will process the form.


Note: Get this information from your site administrator.


Figure 2 Blank form


Figure 3 Method menu in the Property 
inspector
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Adding form elements


Using the Forms category in the Insert panel, you can insert any combination of form elements within the red outline 
of the form. You can use tables to lay out these elements if you choose.


Using form fields


Form fields enable site visitors to enter text into a form. Form fields include the following:


• Text fields, in which a visitor types a response


• File fields, in which a visitor types the path of a file to upload to your server


Adding text fields


Text fields provide a space in which visitors can enter text.


To add a text field:


1. Click the Text Field button in the Insert panel.


The Input Tag Accessibility Attributes dialog box opens 
(Figure 4).


2. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the text field in the ID text box. You 
may use any combination of letters, numbers, and an 
underscore (_).


The ID is used by HTML and/or Javascript code to 
distinguish this input tag from others, but it isn’t visible 
to site visitors.


3. Enter a label for the text field in the Label text box. You 
can leave the other properties in the dialog box at their 
default values. 


The label will be displayed next to the text field, 
indicating to the visitor what to put in the field.


4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box.


5. In the Add Form Tag dialog box, click Yes.


The text field appears in the form (Figure 5).


6. Click in the text field (not the label) to select it.


7. In the form Property inspector (Figure 6), select one of 
the three types of text fields:


• Single Line text for short answers


• Multi Line text for long answers such as the visitor’s 
description of a problem with a purchased item


• Password text for passwords (in which asterisks 
appear in place of typed characters)


Note: You can also create a multiple-line text field by 
clicking the Text Area button in the Insert panel.


Figure 4 Input Tag Accessibility Attributes dialog 
box


Figure 5 Example of text field in the form


Figure 6 Form Text Field Property inspector
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Adding a file field


A file field enables site visitors to select a file on their computers (such as a word-processing document or graphics 
file) and upload it to your server. A file field looks like other single-line text fields, except it also provides a Browse 
button. The visitor either types the path to the file they want to upload or uses the Browse button to locate and select 
the file.


To add a file field:


1. Click the File Field button in the Insert panel.


The Input Tag Accessibility Attributes dialog box opens


2. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the file field in the ID text box. You 
may use any combination of letters, numbers, and an 
underscore (_).


3. Enter a label for the file field in the Label text box. You 
can leave the other properties in the dialog box at their 
default values. 


4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box.


The file field appears in your document (Figure 7).


5. Click in the file field (not the label) to select it. In the 
Property inspector, in the Char Width text box, specify 
the maximum number of characters visitors will see in 
the field (Figure 8).


6. In the Max Char text box, specify the maximum number 
of characters the field will hold.


Note: Contact your site administrator to confirm that 
anonymous file uploads are allowed before using the file 
field.            


Figure 7 Example of file field


Figure 8 Form File Field Property inspector
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Using checkboxes and radio buttons


Visitors click a checkbox or radio button to make a choice. With checkboxes, visitors can toggle a single option on or 
off, or they can select one or more options from a group of options. With radio buttons, visitors can select only one 
option from a group of options.


To add a checkbox:


1. Click the Checkbox button in the Insert panel.


The Input Tag Accessibility Attributes dialog box opens


2. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the checkbox in the ID text box. You 
may use any combination of letters, numbers, and an 
underscore (_).


3. Enter a label for the checkbox in the Label text box. You 
can leave the other properties in the dialog box at their 
default values. 


4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box.


The checkbox button appears in your document 
(Figure 9).


5. Click the checkbox (not the label) to select it.


6. In the Checked Value text box in the Property inspector 
(Figure 10), enter a value for the checkbox.


This is the value that will be returned by the form. For 
example, for a checkbox that indicates whether a visitor 
wishes to be on a mailing list, you might set a value of 1 
for yes.


7. For Initial State, select Checked if you want an option to 
appear selected when the form first loads in the visitor’s 
browser. Otherwise, select Unchecked.


Figure 9 Example of checkbox


Figure 10 Form Checkbox Property inspector
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To add a group of radio buttons:


1. Click the Radio Group button in the Insert panel to insert 
a group.


The Radio Group dialog box opens (Figure 11).


2. Enter a name in the Name text box.


3. Click the plus (+) button to add a radio button to the 
group.


4. Enter a label and (if you want) a checked value for each 
button.


5. Select an item in the radio button list, and click the up or 
down arrows to reorder the buttons.


6. Select Line Breaks to arrange the radio buttons without 
using a table. Select Table to arrange them in a table. 


7. Click OK.


The group of radio buttons is added to the form 
(Figure 12).


8. Click a radio button (not its label) to select it.


9. In the Property inspector, click Checked or Unchecked to 
indicate if this option is selected by default (Figure 13).


Figure 11 Radio Group dialog box


Figure 12 Example of Radio Group


Figure 13 Form Radio Button Property inspector
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Using list menus and drop-down menus (List/Menu)


Lists and menus allow visitors to select options from a list or pop-up menu. With a list menu, you can display 
multiple options in a confined space and allow visitors to select multiple items. Visitors can select only one item from 
a pop-up menu.


To add a list menu:


1. Click the List/Menu button (Windows) or Select (List/
Menu) button (Mac OS).


The Input Tag Accessibility Attributes dialog box opens.


2. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the list menu in the ID text box. You 
may use any combination of letters, numbers, and an 
underscore ( _ ).


3. Enter a label for the list menu in the Label text box. You 
can leave the other properties in the dialog box at their 
default values. 


4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box.


A list/menu field appears in your document (Figure 14).


5. Click the list/menu field (not its label) to select it.


6. In the Property inspector, for Type, select List 
(Figure 15).


7. In the Height text box, enter the number of items the list 
will display.


If this number is less than the total number of items in the 
list, a scroll bar will be displayed.


8. If you want to allow visitors to select more than one item 
in the list, select Allow Multiple for Selections.


9. Click the List Values button to add the list items.


The List Values dialog box opens (Figure 16).


10. With the insertion point in the Item Label text box, enter 
the text you want to appear in the list.


11. In the Value text box, enter data you want sent to the 
server when a visitor selects the item.


If you enter no value, then the form sends the label as the 
value for that item.


12. Press Enter (Windows) or Return (Mac OS).


13. To add another item to the list, click the plus (+) button.


14. When you finish, click OK to close the List Values dialog 
box.


15. To have one of the items in the list selected by default, 
select that item in the Initially Selected text box in the 
Property inspector (Figure 17).


Figure 14 Example of list/menu field


Figure 15 Form List Menu Property inspector


Figure 16 List Values dialog box 


Figure 17 Choose which item is initially selected
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The Initially selected item appears in the form 
(Figure 18).


Figure 18 Form list with three items in the list


To add a drop-down menu:


1. Click the List/Menu button (Windows) or Select (List/
Menu) button (Mac OS).


The Input Tag Accessibility Attributes dialog box opens.


2. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the pop-up menu in the ID text box. 
You may use any combination of letters, numbers, and an 
underscore (_).


3. Enter a label for the pop-up menu in the Label text box. 
You can leave the other properties in the dialog box at 
their default values. 


4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box.


A list/menu field appears in your document (Figure 19).


5. Click the list/menu field (not its label) to select it. 


6. In the Property inspector, for Type, select Menu.


7. Click the List Values button to add the menu items.


The List Values dialog box opens (Figure 20).


8. With the insertion point in the Item Label text box, enter 
the text you want to appear in the menu.


9. In the Value text box, enter data you want sent to the 
server when a visitor selects the item.


10. Press Enter (Windows) or Return (Mac OS).


11. To add another item to the menu, click the plus (+) 
button.


12. When you finish, click OK to close the List Values dialog 
box.


13. To have one of the items in the menu selected by default, 
select that item in the Initially Selected text box in the 
Property inspector. 


Note: To see the menu items in operation,  preview this 
page in a browser (Figure 21).


Figure 19 A list/menu field


Figure 20 List Values dialog box


Figure 21 Preview in a browser
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Using form buttons


Form buttons control form operations. Use a form button to submit data entered into a form to the server or to reset 
the form. There are two types of form buttons: Standard text buttons are the browser's default button style, with text 
you want to display (typically Submit, Send, or Reset); graphical buttons use the graphic of your choice.


To add a standard text button:


1. Click the Button button in the Insert panel.


The Input Tag Accessibility Attributes dialog box opens.


2. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the button in the ID text box. You may 
use any combination of letters, numbers, and an 
underscore (_).


Note: There are two reserved names: Submit, which 
submits the form data for processing, and Reset, which 
resets all the form fields to their original values.


3. Don’t enter a label for the button. Click OK to close the 
Input Tag Accessibility Attributes dialog box.


Note:  A label would appear next to the button, rather 
than on it, so you don’t want a label for a button form 
element. The text on the button itself is set by the button’s 
value attribute, which you will set in the next step.


A text button appears in the document (Figure 22).


Note: In this example, a Submit button is placed below 
an existing file field.


4. Click the button to select it.


5. In the Property inspector’s Value text box, enter the text 
you want to appear on the button (Figure 23).


Note: It’s a good idea to set the value to whatever the 
button does. “Submit” is a good choice, but you might 
also consider brief phrases in the forms of commands (for 
example, “Send Message” or “Update Profile” or 
“Register”).


6. Select the type of Action (usually this is Submit Form).


Figure 22 Example of text button


Figure 23 Form Button Property inspector
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Adding a graphical submit button


You can use images as submit button icons. Using an image to perform tasks other than submitting data requires 
attaching a behavior to the form object by using the Behaviors panel.


To add a graphical submit button:


1. Click the Image Field button in the Insert panel.


The Select Image Source dialog box appears (Figure 24).


2. Locate and select the image to use as the submit button 
icon; then click OK (Windows) or Choose (Mac OS).


The Input Tag Accessibility Attributes dialog box opens.


3. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the button in the ID text box. You may 
use any combination of letters, numbers, and an 
underscore (_).


Note: There are two reserved names: Submit, which 
submits the form data for processing, and Reset, which 
resets all the form fields to their original values.


4. Don’t enter a label for the button. Click the OK button to 
close the Input Tag Accessibility Attributes dialog box.


The graphical submit button appears in your document 
(Figure 25).


5. Click the button to select it.


6. In the Alt text box, type alternate text you want to appear 
in place of the image for text-only browsers (Figure 26). 
This should match any text displayed on the button.


Note: You can also click the folder icon beside the Src 
text box to select a new image for the button.


Figure 24 Select Image Source dialog box


Figure 25 Example of graphical submit button 


Figure 26 Form Image Field Property inspector
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Using jump menus for navigation


A jump menu is a pop-up menu with options that link to documents or files. It is a form element that acts as 
navigation. You can create links to documents in your website or other websites, e-mail links, links to graphics, or 
links to any file type that can be opened in a browser. Because using this type of menu will cause the browser to 
navigate to another page, don’t mix jump menus with other form elements.


To add a jump menu:


1. Click the Jump Menu button in the Insert panel.


The Insert Jump Menu dialog box opens (Figure 27).


2. Complete the dialog box.


For more information, click the Help button in the dialog 
box.


3. Click OK.


Figure 27 Insert Jump Menu dialog box
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How to use templates
You can use an Adobe Dreamweaver CS5 template to create multiple pages with the same layout. In a template, you 
control which page elements should remain constant in documents based on that template and which elements can be 
changed from page to page. Templates are helpful for building a website in which most pages have the same header, 
navigation system, and other elements. Using templates helps you save time as well as create and maintain a 
consistent look when more than one person is developing a site.


Creating a template


You create templates from existing pages, setting editable regions on these pages that will hold content on each page 
created from the template.


To create a template:


1. Start Dreamweaver.


2. Build a page that contains elements designed to appear 
on all content pages such as common graphics, a 
navigation bar, and common layout structures such as div 
tags (Figure 1).


Note: You may want to create navigation elements in 
Adobe Fireworks CS5 and export them as HTML 
documents.


3. Select File > Save As Template.


4. In the Save As Template dialog box (Figure 2), give the 
template a name. You can also enter a brief description of 
the template. Then click Save. If Dreamweaver asks if 
you want to update links, click Yes.


Dreamweaver creates a Templates folder in your site root 
folder and saves your template in that folder. Template 
files have a .dwt file extension.


Figure 1 Common elements on a web page


Figure 2 Save As Template dialog box
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To create an editable region:


1. In the Layout category of the Insert panel, click Draw AP 
Div, and then drag on the page to create a new div to 
represent the editable region in the template.


Note: You also click to indicate where to place the 
editable region, but using a div gives you more control 
over page layout. 


2. With the div still selected, do one of the following to 
create an editable region:


• Select Insert > Template Objects > Editable Region.


• Right-click (Windows) or Control-click (Mac OS) 
the region and select Templates > New Editable 
Region from the context menu.


• In the Common category of the Insert panel, click the 
Templates button (Figure 3), and select Editable 
Region from the pop-up menu.


The New Editable Region dialog box opens (Figure 4).


3. In the dialog box, enter a unique name for the region, and 
click OK.


The editable region is within the selected div, and is 
enclosed in a light blue rectangle on the template 
(Figure 5).


Note: You cannot use the same name for more than one 
editable region in a particular template. Use only letters 
and numbers in the name.


4. Save and close the template.


Figure 3 Templates button on the Insert panel


Figure 4 New Editable Region dialog box


Figure 5 New editable region inside the div


Templates
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To create a document based on a template:


Once you create a template, you can use it to create new 
documents.


1. Select File > New.


2. Save the new page and give it a name, such as 
index.html.


3. In the New Document dialog box, select the Page From 
Template category.


The dialog box displays your sites and all of the 
templates for the selected site (Figure 6).


4. In the Sites list, select the site that contains the template 
you want to use.


5. Select the template you want to use.


6. Make sure the Update Page When Template Changes 
option is selected.


With this option selected, Dreamweaver can update all 
template-based pages if you change the template later.


7. Click Create to create a new template-based page.


The document opens in the Document window.


8. Click in one of the editable regions, and add text.


9. Move the pointer over a page area that is not editable, and 
observe that you cannot make changes.


10. Save the page.


Figure 6 Page From Template category in the New 
Document dialog box
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Editing a template


You can edit a template at any time, even if you have created pages based on the template.


To edit a template:


1. Select Window > Assets.


The Assets panel opens.


2. Click the Templates button on the left side of the panel 
(Figure 7).


A list of the templates for your site appears in the lower 
pane. The upper pane displays a preview of the selected 
template. (You may need to scroll the preview pane to see 
this.)


3. Select the template you wish to edit and do one of the 
following:


• Double-click the name of the template.


• Click the Edit button at the bottom of the panel 
(Figure 7).


4. Edit the template in the Document window, changing 
non-editable elements or creating editable regions in the 
template as desired.


5. Save the edited template by choosing File > Save.


The Update Template Files dialog box opens, with a list 
of the documents based on your template (Figure 8).


Figure 7 Assets panel


Figure 8 Update Template Files dialog box


6. Click Update to update the documents based 
on the changes you made in your template.


If you have enabled check in/check out, and 
the files to be updated are currently checked 
in, Dreamweaver asks to check these out 
before it can update them.


If you have changed or deleted editable 
regions, Dreamweaver may warn you that 
editable region names are inconsistent with 
files that have been created based on the 
template.


To resolve this problem, take the following 
steps:


a. In the Inconsisten Region Names dialog 
box (Figure 9), select a region from the 
list.


b. In the Move Content To New Region 
menu, select a new region in which you 
want to place the content from the 
selected region .


Templates


Edit
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c. Repeat these steps  for the remaining regions in the 
list.


7. Click OK.


The Update Pages dialog box displays a summary of the 
updates performed (Figure 10). You may need to select 
Show log to view the Status information.


8. Click Close.


Figure 9 Inconsistent Region Names dialog box 
with Move Content To New Region menu


Figure 10 Update Pages dialog box


Deleting a template


To delete a template:


1. Select the template in the Assets panel.


2. Click the Delete button (trash can icon) at the bottom of the panel and confirm that you want to delete the 
template.


The template file is deleted from your site.


Documents that were based on a template you have deleted retain the structure and editable regions the template 
file had before you deleted it. To turn such a document into a normal HTML file without editable or locked 
regions, you must detach it from the template.
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Detaching from a template


To remove the template structure and constraints from a document based on a template, you can detach the document 
from the template. When a document is detached from its template, you can edit any element, including the regions 
that were previously locked.


To detach a file from a template


1. To detach a document from a template, open the document.


2. Select Modify > Templates > Detach From Template.





		How to use templates

		Creating a template

		Editing a template

		Deleting a template

		Detaching from a template












Digital Design Activity 7.1 Guide


© 2010 Adobe Systems Incorporated How to make websites accessible 1


How to make websites accessible
Increasingly, government, corporate, and non-profit standards call for making websites accessible--making them 
readable for users with disabilities. These users may have screen readers and other interpretive devices. To make your 
site accessible, consider the following techniques.


Alternate text


Alternate text for images is critical for many devices that assist disabled people to access the web. The Property 
inspector in Adobe Dreamweaver CS5 has an Alt text box for entering alternative text for an image, link, or button. 
The text can be descriptive and as long as necessary, but it should be as succinct as possible.


Cascading Style Sheets (CSS)


Developers use CSS to separate content from presentation of their websites, allowing assisting devices easier access 
to the information provided in the content. Developers also use CSS to create a consistent structure for text content, 
aiding interpretive devices (such as text-to-speech browsers).


Image maps


Provide alternate text for hot spots in images to make them readable by interpretive devices.


Tables


Provide alternate text descriptions for tables, such as identifiers of row and column headings for data tables or longer 
descriptions for tables with textural information.
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Templates and library objects


Designers can create a single, accessible template or a small set of templates as the basis of the entire site. Templates 
limit mistakes when multiple designers are working on a site. In addition, templates foster a consistent, easy-to-use 
site that keeps visitors oriented and has consistent common elements such as navigation bars.


Frames


Add descriptions of frames in the Adobe Dreamweaver CS5 Property inspector. This alternative text provides 
additional information to web browsers and readers as visitors navigate each frame.


Movies


Use the Accessibility panel in Adobe Flash Professional CS5 to provide text equivalents where appropriate. If there 
are movie elements that are purely decorative, are repetitive, or otherwise convey no content, then make those 
elements inaccessible by deselecting the option, “Make Object Accessible.” Use the Description section of the panel 
to provide context for the entire movie.


Device independence


Device independence means that your web page should not require a particular hardware device in order to use it. For 
instance, the page should not require that the user have a mouse in order to use it—all controls should be manageable 
from the keyboard. Provide a keyboard equivalent for each button, and include all links and buttons in the tab index, 
so that visitors can use the Tab key to move from one element to the next. 


Use the Behaviors panel in Dreamweaver to create rollovers and other scripts that are triggered by logical events, 
such as onFocus and onBlur. Create scripts that combine mouse events with logical events to support a variety of 
visitors. For more about behaviors, see “Adding JavaScript behaviors” in Dreamweaver Help (in Dreamweaver, 
select Help > Dreamweaver Help).
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